Service Health

This page provides status information on the services that are part of Google Cloud. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact Support. Learn more about what's posted on the dashboard in this FAQ. For additional information on these services, please visit https://cloud.google.com/.

All incidents reported for Google Cloud Console

2024

Summary Date Duration
Cloud Billing Issue : Increased error rate for Cloud Billing API calls 4 Apr 2024
1 hour, 4 minutes
Issue with Google Cloud Console, Cloud Workstation, Cloud Shell, GKE and Persistent Disk. 27 Feb 2024
2 days
Multiple Google Cloud Products are experiencing issues in us-west1 14 Feb 2024
3 hours, 7 minutes
Multiple Google Cloud products are impacted by a Cloud Monitoring issue 10 Jan 2024
1 day, 20 hours

2023

Summary Date Duration
Customers might be unable to activate automatic offer approval 12 Dec 2023
5 hours, 44 minutes
Elevated errors in Google Cloud Console 7 Dec 2023
1 hour, 32 minutes
Duet AI Chat Panel Loading Issues in Google Cloud Console. 25 Oct 2023
1 hour, 11 minutes
Issues for Cloud console iOS users while accessing SQL instances, app engine charts and dashboard widgets with App engine related metrics. 25 Oct 2023
14 hours, 13 minutes
We are experiencing an issue with Google Cloud Console 23 Oct 2023
21 minutes
Google Cloud console customer may experience crashes after updating to Chrome `Version 118.0.5993.70' for Chrome on MAC 17 Oct 2023
1 day, 22 hours
'Signup with provider' option is not appearing when making public purchases 6 Oct 2023
53 minutes
Customers are not able to receive budget notifications. 2 Sep 2023
4 hours, 45 minutes
A limited number of customers could experience issues with accessing Google Cloud Console resources 30 Aug 2023
4 hours, 15 minutes
Multiple GCP products affected by Increased error rates for Google Cloud APIs in us-central1 3 Aug 2023
2 hours, 13 minutes
Google Cloud Console customers using IAM are unable to add or remove users to and from projects. 26 Jun 2023
1 hour, 31 minutes
Customers experiencing a longer load time while visiting /getting-started page in Google Cloud Console 29 May 2023
4 hours, 39 minutes
Elevated gcloud crashes for service account users 2 May 2023
2 hours, 34 minutes
This incident is being merged with an existing incident. All future updates will be provided there: https://status.cloud.google.com/incidents/dS9ps52MUnxQfyDGPfkY 26 Apr 2023
51 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 26 Apr 2023
1 hour, 34 minutes
Multiple Google Cloud services in the europe-west9-a zone are impacted 25 Apr 2023
1 day, 3 hours
Cloud Billing: Latency and errors displaying billing pages in Cloud Console 24 Apr 2023
2 hours, 34 minutes
Cloud Marketplace customers may experience API Library products are not being displayed 23 Feb 2023
54 minutes
Google Cloud Console customers might experience Cloud Billing data delays 16 Feb 2023
2 hours, 58 minutes
Google Engineer are investigating an issue with BigQuery UI 15 Jan 2023
51 minutes
Google Cloud Console Marketplace is experiencing 404 errors. 12 Jan 2023
3 hours, 32 minutes
This incident is being merged with an existing incident. All future updates will be provided there: https://status.cloud.google.com/incidents/zpBMVGTUdxSizQQF948M 12 Jan 2023
2 hours, 50 minutes

2022

Summary Date Duration
Customers are unable to create or modify L7 Internal Load balancers using the Cloud Console UI with the logging option enabled 14 Dec 2022
19 days, 21 hours
Global: G Cloud Command loading performance issue 12 Dec 2022
5 hours, 32 minutes
Google Cloud iOS mobile app errors 7 Dec 2022
1 day, 2 hours
We are investigating a potential issue with multiple Google Cloud services. 14 Nov 2022
48 minutes
Google Cloud Console is experiencing issue with displaying the list of compute instances. 26 Sep 2022
6 hours, 32 minutes
Billing User Interfaces are unable to load the data consistently 1 Aug 2022
2 hours, 29 minutes
Google Cloud Console Transfer Appliance Order Incorrectly Routed in Singapore Region 25 Jul 2022
7 hours, 22 minutes
Cloud Billing usage reporting is experiencing issues, and Cost Management experience may show incomplete data. 25 Jul 2022
9 days, 3 hours
Global: Some Google Cloud Console Customers are unable to create/edit GCE instances 14 Jun 2022
2 days, 8 hours
Contact Support Widget is down 9 Feb 2022
6 hours, 5 minutes

2021

Summary Date Duration
Issue with Cloud Bigtable 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components. 12 Nov 2021
1 hour, 44 minutes
Issue with Google Cloud SQL 12 Nov 2021
1 hour, 44 minutes
We are experiencing Networking issues 12 Nov 2021
1 hour, 44 minutes
Issue with Google Cloud components 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
Issue with Container Analysis API 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
Issue with Google App Engine 12 Nov 2021
1 hour, 44 minutes
Global: Issues with populating a UI element in Cloud Console for Cloud Run, Google Container Registry and Artifacts Registry 20 Oct 2021
1 day, 1 hour
us-west1: Cloud Logging experiencing elevated error rate while reading logs 18 Oct 2021
2 hours, 14 minutes
We experienced an issue with Cloud Console where customers observed warning notifications related to payment method, beginning at Wednesday, 2021-09-22 14:10 US/Pacific. 22 Sep 2021
10 hours, 20 minutes
Google Cloud Storage UI is experiencing some issues 2 Sep 2021
10 hours
Talent solutions view is unavailable in Cloud Console 11 Jun 2021
53 minutes
Issue with multiple Google Cloud infrastructure components. 20 May 2021
10 hours, 45 minutes
We are experiencing an issue with Cloud Shell 4 May 2021
19 minutes

2020

Summary Date Duration
Google Cloud services are experiencing issues and we have an other update at 5:30 PDT 14 Dec 2020
2 hours, 16 minutes
We are experiencing an issue with loading several pages in the Cloud Console, including modifying External HTTP(S) Load Balancer configurations. 12 Nov 2020
22 hours, 46 minutes
Cloud Shell Connectivity Issues in asia-southeast1 and an issue with the Pricing UI not loading for some billing accounts with a custom price model has been resolved. 24 Sep 2020
18 hours, 22 minutes
Cloud Console pages with prefix of :*/billing/:accountId/" are returning errors 18 Sep 2020
2 hours, 49 minutes
Customers May be Unable to Create Support Cases via the Cloud Console 21 Jul 2020
1 hour, 19 minutes
We Are Investigating an Issue with the Cloud Console 26 Mar 2020
10 hours, 39 minutes
We are investigating an issue in Cloud Console 26 Mar 2020
37 minutes
Elevated error rates across multiple Google Cloud Platform services. 26 Mar 2020
13 hours, 41 minutes
The issue with Cloud Console has been partially resolved as of 09:10 US/Pacific. 7 Feb 2020
1 hour, 49 minutes
Several Cloud console pages experiencing slow loading and loading errors. 5 Feb 2020
5 hours

2019

Summary Date Duration
We've received a report of an issue with Cloud Firestore. 11 Nov 2019
2 hours, 21 minutes
We are currently experiencing an issue with authentication to Google App Engine sites, the Google Cloud Console, Identity Aware Proxy, and Google OAuth 2.0 endpoints. 19 Aug 2019
1 hour, 57 minutes
Cloud Console Dashboard Errors 25 Jul 2019
14 hours, 46 minutes
Users trying to add API restrictions to an API key in Cloud Console may see an incomplete list of possible APIs to restrict their keys to. 6 Jun 2019
16 hours, 24 minutes
The network congestion issue in eastern USA, affecting Google Cloud, G Suite, and YouTube has been resolved for all affected users as of 4:00pm US/Pacific. 2 Jun 2019
3 hours, 55 minutes
Increased latency and occasional errors while accessing Google Cloud Console. 10 May 2019
10 minutes
Errors showing up in various areas in the Cloud Console 2 May 2019
1 hour, 53 minutes
The Google Cloud Console service is experiencing an issue with elevated latency when starting Cloud Shell consoles. 26 Apr 2019
2 hours, 29 minutes