Service Health

This page provides status information on the services that are part of Google Cloud. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact Support. Learn more about what's posted on the dashboard in this FAQ. For additional information on these services, please visit https://cloud.google.com/.

All incidents reported for Google App Engine

2023

Summary Date Duration
Google App Engine (GAE) Flex new deployments were experiencing issues with app availability. 6 Dec 2023
12 hours, 27 minutes
Customer experiencing a requests to Secret Manager timeout for App Engine and Cloud Run. 8 Nov 2023
2 hours, 18 minutes
Cloud Run and App Engine fail to serve some requests in us-east4, northamerica-northeast1 and northamerica-northeast2 23 Oct 2023
2 hours, 49 minutes
Multiple services for Google Cloud Platform are impacted in us-central1-a 12 Sep 2023
3 hours, 46 minutes
Elevated serving latency for App Engine and Cloud Functions gen1 in multiple regions: asia-east1, us-west3, us-west4 8 Aug 2023
29 minutes
Google App Engine users may observe latency in multiple regions 6 Aug 2023
39 minutes
Multiple Google Cloud Platform services impacted globally with operational latency 12 Jun 2023
4 hours, 33 minutes
We are experiencing an issue impacting Serverless Java runtime deployments for Google Cloud Functions and Google App Engine and 9 Jun 2023
5 hours, 20 minutes
Multi-Region: Legacy Image API returning high number of errors. 16 May 2023
2 hours, 47 minutes
We've received a report of an issue with Google App Engine 30 Mar 2023
7 hours, 8 minutes
Google engineers are investigating an issue with Google App Engine 28 Mar 2023
7 hours, 9 minutes
us-central1: Flex CreateVersion failures for Google App Engine custsomers. 21 Mar 2023
23 minutes
Global: Google App Engine Deployment Failures 16 Mar 2023
3 days, 17 hours
us-central1: App Engine Flex errors when attempting to create version 14 Mar 2023
2 hours, 42 minutes
Global: Deployment failures for Google App Engine Flex 9 Mar 2023
9 minutes
Global: Deployment failures for Google App Engine Flex 9 Mar 2023
1 hour, 34 minutes
Google App Engine Flex users experiencing issues with deploying some applications using gcloud 417.0.0 7 Feb 2023
23 hours, 8 minutes
Google are currently investigating a issue Google cloud networking, Google App Engine. 5 Feb 2023
2 hours, 37 minutes
Google App Engine app creation failing in australia-southeast1 4 Jan 2023
2 hours, 21 minutes

2022

Summary Date Duration
Logs delayed in europe-west3 14 Dec 2022
3 hours, 11 minutes
Multiple products may return error messages across Asia/Australia 9 Dec 2022
3 hours, 5 minutes
App Engine Flexible Create Update and Delete endpoints failing 1 Dec 2022
1 hour, 16 minutes
We are experiencing an issue with App Engine GEN1 Users API. 17 Nov 2022
3 minutes
We are experiencing issues in App Engine Flexible and Cloud Composer 8 Nov 2022
1 hour, 26 minutes
App Engine: Flex deployment operations failing 7 Nov 2022
1 hour, 21 minutes
App Engine Standard deployments issues in asia-south1 30 Aug 2022
59 minutes
Cloud Monitoring is serving query failures, errors, and metrics unavailability impacting Google Compute Engine, Cloud Spanner, Cloud Dataflow, Cloud Bigtable, Cloud AppEngine, Kubernetes Engine, Cloud Pub/Sub, Cloud Run in us-central 20 Aug 2022
2 hours, 55 minutes
Multiple Cloud products experiencing elevated error rates, latencies or service unavailability in europe-west2 19 Jul 2022
1 day, 15 hours
[Global] Google App Engine - Customers using the Secrets Manager are experiencing increased errors. 8 Jun 2022
6 days, 11 hours
us-east1: Elevated errors affecting multiple services. 4 Jun 2022
6 hours, 16 minutes
Degraded serving for Google App Engine and Cloud Functions users in us-central1 24 May 2022
49 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 9 May 2022
24 minutes
This incident is being merged with an existing incident. All future updates will be provided there: https://status.cloud.google.com/incidents/eWat683pNnkMT7orVDBV 8 May 2022
1 hour, 47 minutes
Google Cloud Infrastructure is failing to push cloud configs 8 May 2022
3 hours, 18 minutes
Google App Engine Increased Latency in us-central1 28 Apr 2022
1 hour, 32 minutes
Global: Delays creating or modifying load balancer configurations 31 Mar 2022
4 hours, 6 minutes
Google engineering are investigating issues with Cloud Networking, starting at 2022-02-10 00:32:56 PST 10 Feb 2022
6 hours, 2 minutes

2021

Summary Date Duration
Global: Google App Engine Flex customers getting 404 errors on their websites. 16 Nov 2021
21 minutes
Multi-Region: App Engine experiencing network traffic issues 16 Nov 2021
24 minutes
Global: Experiencing Issue with Cloud networking 16 Nov 2021
1 hour, 54 minutes
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
Issue with Container Analysis API 12 Nov 2021
1 hour, 44 minutes
Issue with Google Cloud components 12 Nov 2021
1 hour, 44 minutes
Issue with Google Cloud SQL 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components. 12 Nov 2021
1 hour, 44 minutes
Issue with Google App Engine 12 Nov 2021
1 hour, 44 minutes
We are experiencing Networking issues 12 Nov 2021
1 hour, 44 minutes
Issue with Cloud Bigtable 12 Nov 2021
1 hour, 44 minutes
Global: Some Cloud Monitoring metric calculations are delayed or missing for multiple Cloud Services 13 Oct 2021
5 hours, 25 minutes
us-central1: Cloud Functions experiencing increased latency and pending queue aborted error request rate. 7 Sep 2021
23 hours, 41 minutes
us-central1: Google App Engine Standard experiencing increased latency and pending queue aborted error request rate. 7 Sep 2021
23 hours, 41 minutes
europe-west2-c: Cloud networking is currently experiencing issues. 3 Sep 2021
40 minutes
Issue with multiple Google Cloud infrastructure components. 20 May 2021
10 hours, 45 minutes
Customers may see excessive delays or errors when attempting to deploy App Engine Flex instances globally 12 May 2021
1 hour, 28 minutes
Customers may experience increased failures when executing Cloud Tasks scheduler jobs in us-central1. 24 Mar 2021
2 hours, 20 minutes
Increased latency and packet loss 17 Mar 2021
4 hours, 30 minutes
Google App Engine Flex deployments are seeing increased errors in us-central1, us-east1 and us-east4, us-west3, europe-west6 18 Feb 2021
1 hour, 40 minutes
Our engineers have determined this issue to be linked to a single Google incident. For regular status updates, please visit https://status.cloud.goog 12 Feb 2021
4 hours, 5 minutes
Google App Engine services in multiple regions may experience errors 5 Feb 2021
1 hour, 35 minutes

2020

Summary Date Duration
GAE Cloud Monitoring Metrics are not being ingested. 5 Nov 2020
1 hour, 21 minutes
App Engine Standard returning elevated HTTP 500 errors in us-central1 6 Oct 2020
1 hour, 35 minutes
We are experiencing an issue with App Engine in asia-east2 17 Sep 2020
1 hour, 29 minutes
We are experiencing issues across multiple GCP products 19 Aug 2020
3 hours, 50 minutes
We are experiencing issues with Google App Engine, increased error rate for instance creation 19 Aug 2020
6 hours, 18 minutes
We are experiencing an issue affecting multiple Cloud services. 23 Jul 2020
1 hour, 58 minutes
New App Engine Deployments May Time Out and Fail 15 Jul 2020
1 hour
We are investigating an issue with elevated error rates across multiple Google Cloud Platform Services 8 Apr 2020
54 minutes
The issue with Google App Engine is believed to be linked to a single Google incident. 26 Mar 2020
1 hour, 11 minutes
Elevated error rates across multiple Google Cloud Platform services. 26 Mar 2020
13 hours, 41 minutes
Elevated deployment errors 17 Jan 2020
44 minutes

2019

Summary Date Duration
We've received a report of an issue with Cloud Firestore. 11 Nov 2019
2 hours, 21 minutes
We've received a report of an issue with Google App Engine. 11 Nov 2019
1 hour, 40 minutes
We've received a report of issues with Google Cloud App Engine. 31 Oct 2019
15 hours, 34 minutes
Some networking update/create/delete operations pending globally 31 Oct 2019
1 day, 22 hours
We've received a report of issues with multiple Cloud products. 24 Sep 2019
5 hours, 8 minutes
We've received a report of an issue with Google App Engine. 3 Sep 2019
4 hours, 31 minutes
The issue with Google App Engine application creation should be resolved for the majority of users. 25 Jul 2019
14 hours, 46 minutes
The network congestion issue in eastern USA, affecting Google Cloud, G Suite, and YouTube has been resolved for all affected users as of 4:00pm US/Pacific. 2 Jun 2019
3 hours, 55 minutes
We are investigating elevated error rate on publish/pull and various admin operations (i.e. create/delete/get topics) with Google Cloud PubSub globally. 20 May 2019
3 hours, 30 minutes