Service Health

This page provides status information on the services that are part of Google Cloud. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact Support. Learn more about what's posted on the dashboard in this FAQ. For additional information on these services, please visit https://cloud.google.com/.

All incidents reported for Google Kubernetes Engine

2024

Summary Date Duration
Cloud Customers may experience minimal service disruption in us-east5-c 28 Mar 2024
3 hours, 32 minutes
Customers using Container-Optimized OS (COS) in Google Kubernetes Engine (GKE) were not able to fetch specific NVIDIA GPU drivers. 12 Mar 2024
6 hours, 55 minutes
Issue with Google Cloud Console, Cloud Workstation, Cloud Shell, GKE and Persistent Disk. 27 Feb 2024
2 days
Multiple Google Cloud Products are experiencing issues in us-west1 14 Feb 2024
3 hours, 7 minutes
Multiple product outage in europe-west8-b 7 Feb 2024
1 hour, 59 minutes

2023

Summary Date Duration
Google Kubernetes Engine customers with Workload Identity enabled may see high application logging rate 2 Nov 2023
8 days, 4 hours
Multiple cloud products are experiencing networking issues in us-central1 5 Oct 2023
7 hours, 47 minutes
Google Kubernetes Engine Nodepool Upgrade Failures 2 Oct 2023
10 days, 1 hour
We are experiencing an issue with Google Kubernetes Engine 13 Sep 2023
14 days, 21 hours
Multiple services for Google Cloud Platform are impacted in us-central1-a 12 Sep 2023
3 hours, 46 minutes
GPU device plugin component version 0.1.11-gke.1 causing missing GPU features in 1.23 and 1.24 11 Jul 2023
1 day, 4 hours
Customers may see unexpected additional messages in GKE cluster logs. 6 Jul 2023
12 days
Multiple products reporting 403 access denied issue in us-west1 and multiregion-us 19 Jun 2023
6 hours, 45 minutes
Google Compute Engine and Google Kubernetes Engine are experiencing issues with some instance, node, cluster operations 8 Jun 2023
1 hour, 13 minutes
us-east1: Multiple Google Cloud Services Impacted 4 Jun 2023
1 hour, 43 minutes
Multiple Cloud products impacted in europe-west9-c zone 6 May 2023
4 hours, 30 minutes
Multiple Google Cloud services in the europe-west9-a zone are impacted 25 Apr 2023
1 day, 3 hours
GKE Autoscaler may be experiencing issues with scale up for customer in us-west1 9 Feb 2023
43 minutes
Google Kubernetes Engine Autopilot cluster creation, Google Cloud Dataproc serverless job submission and Google Cloud Composer environment creation are experiencing elevated error rates. 7 Feb 2023
8 hours, 3 minutes
Horizontal Pod Autoscaler (HPA) doesn't work in newly created GKE Minor version 1.24+ clusters 12 Jan 2023
3 days, 22 hours

2022

Summary Date Duration
us-central1: Degraded performance for Cloud Networking 21 Dec 2022
5 hours, 53 minutes
Calico Node pods failing to start and crash-looping 13 Dec 2022
2 days, 20 hours
Multiple products may return error messages across Asia/Australia 9 Dec 2022
3 hours, 5 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 9 Dec 2022
3 hours, 5 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 9 Dec 2022
3 hours, 5 minutes
Clusters in us-central1 are getting DEADLINE_EXCEEDED errors 8 Dec 2022
30 minutes
Autopilot (clusters versions >= 1.23) may break some workloads 8 Nov 2022
7 hours, 30 minutes
Global: Calico enabled GKE clusters’ pods may get stuck Terminating or Pending after upgrading to 1.22+ 29 Sep 2022
2 days, 1 hour
Global: Calico enabled GKE clusters’ pods may get stuck Terminating or Pending after upgrading to 1.22+ 15 Sep 2022
13 days, 22 hours
Cloud Monitoring is serving query failures, errors, and metrics unavailability impacting Google Compute Engine, Cloud Spanner, Cloud Dataflow, Cloud Bigtable, Cloud AppEngine, Kubernetes Engine, Cloud Pub/Sub, Cloud Run in us-central 20 Aug 2022
2 hours, 55 minutes
GKE cluster control planes unavailable in us-central1-a 1 Aug 2022
1 hour, 10 minutes
Multiple Cloud products experiencing elevated error rates, latencies or service unavailability in europe-west2 19 Jul 2022
1 day, 15 hours
We are experiencing an issue with Google Cloud Networking at us-central1 across multiple products, beginning at Tuesday, 2022-06-14 06:00 US/Pacific. 14 Jun 2022
10 hours, 47 minutes
GKE API seeing high latency and errors in us-central1 14 Jun 2022
3 hours, 19 minutes
us-east1: Elevated errors affecting multiple services. 4 Jun 2022
6 hours, 16 minutes
Customers may experience elevated latency for inter-region in multiple asia regions. 6 May 2022
4 hours, 29 minutes
We are experiencing an issue with Persistent Disk affecting multiple services in us-central1-b 6 May 2022
10 hours, 36 minutes

2021

Summary Date Duration
us-central1-c: GKE experiencing issues with some cluster and nodepool operations. Mitigation Underway. 20 Oct 2021
7 hours, 30 minutes
us-central1-c: GKE experiencing issues with some cluster and nodepool operations. Issue Mitigated. 19 Oct 2021
4 hours, 41 minutes
Global: We have identified a Networking connectivity issue that impacts Docker workloads inside GKE and potentially GCE. Mitigation in progress. ETA - 00:00 PST, 29th Sept. 27 Sep 2021
1 day, 21 hours
Global: Cloud Networking connectivity issues for customers using packet mirroring. 13 Sep 2021
4 days, 15 hours
europe-central2, europe-west3: Elevated error rates for GKE control plane 9 Sep 2021
49 minutes
europe-west2-c: Cloud networking is currently experiencing issues. 3 Sep 2021
40 minutes
GKE service is unaffected. Mitigation for issue with Anthos On-Prem admin workstation access, is underway. See further details below. 26 Aug 2021
11 hours, 18 minutes
We are experiencing a connectivity issue affecting Google Kubernetes Engine in australia-southeast2 23 Aug 2021
1 hour, 13 minutes
Google Cloud infrastructure components faced issues in australia-southeast2 starting 2021-08-23 19:50 PDT. Most of the services are fully restored by 2021-08-23 21:20 PDT. 23 Aug 2021
1 hour, 30 minutes
Issues with GKE 1.20 (lower than 1.20.9-gke.2100) node pools using Docker as runtime. 27 Jul 2021
58 days, 19 hours
Persistent Disk SSD creation is failing in us-east1-{b,c,d}, us-east4-{a,b}, us-west1-c and us-west4-a. This may impact creation of resources which depend on Persistent Disk SSD such as Google Compute Engine, Google Kubernetes Engine, Cloud Composer, Cloud SQL, Cloud Dataproc, and Apigee X in those same regions 19 Jun 2021
3 days, 10 hours
Issue with multiple Google Cloud infrastructure components. 20 May 2021
10 hours, 45 minutes
We are experiencing a global issue with creation and upgrades of GKE Clusters 17 May 2021
1 hour, 54 minutes
Requests to and from Google Kubernetes Engine Instances in us-west2 may see increase traffic loss when using the instance's public IP 4 May 2021
2 hours, 30 minutes
Customers may experience traffic loss across multiple products with requests destined to and from us-west2 4 May 2021
5 hours, 33 minutes
Increased latency and packet loss 17 Mar 2021
4 hours, 30 minutes
We are experiencing an intermittent issue with Google Kubernetes Engine creation 19 Feb 2021
9 hours, 7 minutes
We are experiencing an issue with Google Kubernetes Engine in us-central1 starting at 12:13 US/Pacific. 18 Feb 2021
4 hours, 3 minutes
Our engineers have determined this issue to be linked to a single Google incident. For regular status updates, please visit https://status.cloud.goog 12 Feb 2021
4 hours, 5 minutes
GKE cluster operations may fail in various regions. 1 Feb 2021
1 hour, 3 minutes

2020

Summary Date Duration
Google Cloud services are experiencing issues and we have an other update at 5:30 PDT 14 Dec 2020
2 hours, 16 minutes
We are experiencing an issue with Google Kubernetes Engine in us-central1. 19 Oct 2020
3 hours, 14 minutes
We are currently experiencing an issue with Google Kubernetes Engine customers experiencing elevated rates of packet loss in southamerica-east1-[a, b, c] due to the ongoing Cloud Networking issue beginning at Monday, 2020-10-19 13:05 US/Pacific. 19 Oct 2020
31 minutes
We are experiencing an issue with Google Kubernetes Engine 24 Sep 2020
35 minutes
We are experiencing an issue with GKE in asia-east2 17 Sep 2020
1 hour, 41 minutes
GKE Operations which Create or Delete VMs May Fail or Experience Elevated Latencies 15 Jul 2020
2 hours, 3 minutes
GKE Clusters in us-east1c may be unavailable 29 Jun 2020
4 hours, 37 minutes
We are investigating an issue with elevated error rates across multiple Google Cloud Platform Services 8 Apr 2020
54 minutes
We've received a report of an issue with Google Kubernetes Engine. 26 Mar 2020
1 hour, 52 minutes
Elevated error rates across multiple Google Cloud Platform services. 26 Mar 2020
13 hours, 41 minutes
Description: A small percentage of GKE private clusters are experiencing control plane unavailability after master re-creation is triggered. 24 Feb 2020
10 hours, 18 minutes

2019

Summary Date Duration
We are investigating an issue with Google Kubernetes Engine where some nodes in recently upgraded clusters (see affected versions) may be experiencing elevated numbers of kernel panics 4 Nov 2019
9 days, 4 hours
We are experiencing an issue with Google Kubernetes Engine. 31 Oct 2019
1 day, 17 hours
Some networking update/create/delete operations pending globally 31 Oct 2019
1 day, 22 hours
We are investigating an issue with Google Kubernetes Engine. 22 Oct 2019
2 hours, 31 minutes
We've received a report of an issue with Cloud Networking. 22 Oct 2019
4 hours, 48 minutes
Some Google Kubernetes Clusters are experiencing errors in us-central1, us-west1, and us-west2 10 Oct 2019
2 hours, 11 minutes
We've received a report of an issue with Google Kubernetes Engine. 25 Jul 2019
14 hours, 46 minutes
We've received a report of an issue with Google Kubernetes Engine. 21 Jun 2019
1 hour