Service Health

This page provides status information on the services that are part of Google Cloud. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact Support. Learn more about what's posted on the dashboard in this FAQ. For additional information on these services, please visit https://cloud.google.com/.

All incidents reported for Google Cloud Infrastructure Components

2021

Summary Date Duration
Issue with Google Cloud components 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
Issue with Google Cloud SQL 12 Nov 2021
1 hour, 44 minutes
Issue with Google App Engine 12 Nov 2021
1 hour, 44 minutes
Issue with Cloud Bigtable 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components. 12 Nov 2021
1 hour, 44 minutes
We are experiencing Networking issues 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
We are experiencing a connectivity issue affecting Cloud SQL in australia-southeast2 23 Aug 2021
2 hours, 21 minutes
Google Cloud infrastructure components faced issues in australia-southeast2 starting 2021-08-23 19:50 PDT. Most of the services are fully restored by 2021-08-23 21:20 PDT. 23 Aug 2021
1 hour, 30 minutes
Issue with multiple Google Cloud infrastructure components. 20 May 2021
10 hours, 45 minutes
We are investigating a potential issue with Cloud Shell 8 Mar 2021
53 minutes
We are experiencing an issue with Google Cloud infrastructure components, beginning at Friday, 2021-02-12 14:50 US/Pacific. 12 Feb 2021
4 hours, 26 minutes
We are experiencing network latency in us-central1 and us-east1 19 Jan 2021
2 hours, 44 minutes
Cloud L7 (HTTP) External LB configuration changes propagating with high latency 8 Jan 2021
53 minutes

2020

Summary Date Duration
Google Cloud services are experiencing issues and we have an other update at 5:30 PDT 14 Dec 2020
2 hours, 16 minutes
All Cloud Platform resources in europe-west2-a may be unreachable as of 2020-12-09 18:32 US/Pacific. 9 Dec 2020
1 hour, 23 minutes
We are experiencing an issue with multiple GCP products. 24 Sep 2020
33 minutes
We're experiences issues with Google Cloud infrastructure in asia-east2 17 Sep 2020
1 hour, 20 minutes
We are experiencing issues across multiple GCP products 19 Aug 2020
3 hours, 50 minutes
We were experiencing an issue affecting multiple Cloud services. 23 Jul 2020
2 hours, 32 minutes
We are investigating an issue with elevated error rates across multiple Google Cloud Platform Services 8 Apr 2020
54 minutes
We are experiencing an intermittent issue with Google Cloud infrastructure components. 30 Mar 2020
13 hours, 54 minutes
Elevated error rates across multiple Google Cloud Platform services. 26 Mar 2020
13 hours, 41 minutes
We believe that the issue with Google Cloud infrastructure components has been mitigated. We are continuing to actively monitor the situation. 26 Mar 2020
1 hour, 3 minutes
Deployment Manager error rates are high, also affecting App Engine Flexible and Cloud Composer. 17 Jan 2020
50 minutes

2019

Summary Date Duration
High latency and elevated error rate 9 Dec 2019
3 hours, 18 minutes
Our engineers have determine issue to be linked to a single Google incident. 31 Oct 2019
1 day, 17 hours