Service Health

This page provides status information on the services that are part of Google Cloud. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact Support. Learn more about what's posted on the dashboard in this FAQ. For additional information on these services, please visit https://cloud.google.com/.

All incidents reported for Operations

2024

Summary Date Duration
Multiple Google Cloud Products are experiencing issues in us-west1 14 Feb 2024
3 hours, 7 minutes
Multiple regions: Cloud Logging was experiencing issues with displaying log data in Google Cloud Console 23 Jan 2024
1 day, 13 hours
Multiple Google Cloud products are impacted by a Cloud Monitoring issue 10 Jan 2024
1 day, 20 hours

2023

Summary Date Duration
Cloud Logging exports to Cloud Storage were delayed up to 10h in us-central1 5 Dec 2023
1 day, 11 hours
Cloud Logging customers experiencing issues while querying logs 4 Dec 2023
4 minutes
Cloud Logging customers experiencing issues while querying logs 3 Dec 2023
2 hours, 1 minute
Google Cloud Logging customers are experiencing high error rate and high latency 15 Nov 2023
2 hours, 36 minutes
A few customers may experience a Cloud Logging read log errors 3 Jul 2023
57 minutes
Cloud Profiler not loading for some users in Google Cloud Platform console. 29 Jun 2023
1 hour, 6 minutes
Degraded availability for google.compute.Instance resources 12 Jun 2023
4 days, 1 hour
This incident is being merged with an existing incident. All future updates will be provided there: https://status.cloud.google.com/incidents/dS9ps52MUnxQfyDGPfkY 26 Apr 2023
51 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 26 Apr 2023
1 hour, 34 minutes
Cloud Monitoring users may experience intermittent issues when accessing dashboards or performing queries 7 Apr 2023
32 minutes
Global : Issue With CreateSink method for Cloud Logging 4 Apr 2023
6 hours, 37 minutes
Global: Newly created log-based metrics (LBMs) under Cloud logging will experience failures. 20 Mar 2023
23 hours, 1 minute
Retroactive: Cloud Monitoring Uptime failing to report metrics 24 Feb 2023
1 hour, 56 minutes
Cloud Logs bigquery exports delayed 16 Feb 2023
2 hours, 57 minutes
Google Engineers are investigating an issue with Cloud Logging 19 Jan 2023
14 hours, 8 minutes
Cloud SQL dashboard might be unavailable. 11 Jan 2023
12 hours, 22 minutes

2022

Summary Date Duration
Increase in CreateTimeSeries DEADLINE_EXCEEDED errors globally 15 Dec 2022
2 hours, 37 minutes
Logs delayed in europe-west3 14 Dec 2022
3 hours, 11 minutes
Performance degradation of Cloud Monitoring notifications 8 Dec 2022
1 hour, 49 minutes
Monarch Tcube Query Availability drop in cloud_prod 1 Dec 2022
1 hour, 9 minutes
We are investigating a potential issue with multiple Google Cloud services. 14 Nov 2022
48 minutes
Cloud Logging logs-based metrics data points may be missing or delayed 5 Nov 2022
10 hours, 47 minutes
Failure in Config changes in Cloud Monitoring 25 Oct 2022
49 minutes
Cloud Monitoring - Uptime - 100% error rate in southamerica-east1 28 Sep 2022
17 hours, 55 minutes
Global: Cloud Monitoring Dashboard experiencing issues editing tables 16 Sep 2022
2 hours, 24 minutes
Cloud Monitoring is serving query failures, errors, and metrics unavailability impacting Google Compute Engine, Cloud Spanner, Cloud Dataflow, Cloud Bigtable, Cloud AppEngine, Kubernetes Engine, Cloud Pub/Sub, Cloud Run in us-central 20 Aug 2022
2 hours, 55 minutes
Europe West: Deadline_Exceeded errors across multiple Logs Coliseum endpoints 10 Aug 2022
22 hours, 30 minutes
Cloud Monitoring: Increased latency and errors 12 Jul 2022
23 minutes
GKE API seeing high latency and errors in us-central1 14 Jun 2022
3 hours, 19 minutes
Networking metrics in Cloud Monitoring partially unavailable in europe-west4, us-central* 31 May 2022
2 hours, 25 minutes
Cloud Logging is experiencing elevated latencies for log querying. Customers using global storage buckets or storage buckets in us-central1 to store their logs may see latencies on queries run against Cloud Logging. - Issue Resolved. 17 Apr 2022
20 hours, 41 minutes
Global: Cloud Monitoring Metrics may be unavailable or underreported for Cloud Pub/Sub 31 Mar 2022
7 hours, 24 minutes

2021

Summary Date Duration
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components. 12 Nov 2021
1 hour, 44 minutes
We are experiencing an issue with multiple Google Cloud components {beginning on Friday}, 2021-11-12 00:36 US/Pacific US/Pacific. 12 Nov 2021
1 hour, 44 minutes
Issue with Container Analysis API 12 Nov 2021
1 hour, 44 minutes
Issue with Google Cloud components 12 Nov 2021
1 hour, 44 minutes
Issue with Google Cloud SQL 12 Nov 2021
1 hour, 44 minutes
Issue with Cloud Bigtable 12 Nov 2021
1 hour, 44 minutes
We are experiencing Networking issues 12 Nov 2021
1 hour, 44 minutes
Issue with Google App Engine 12 Nov 2021
1 hour, 44 minutes
Global: Cloud Monitoring returning partial results on some queries 2 Nov 2021
21 minutes
Cloud logs might be unavailable for 25% of customers in global location. 26 Oct 2021
3 hours, 9 minutes
US Multi-Regions: Cloud Logging experiencing elevated error rate while reading logs. Mitigation underway. 19 Oct 2021
9 hours, 41 minutes
Global: Cloud Monitoring elevated errors requesting underlying monitoring data 19 Oct 2021
1 hour, 45 minutes
us-west1: Cloud Logging experiencing elevated error rate while reading logs. Mitigation underway 18 Oct 2021
8 hours, 45 minutes
us-west1: Cloud Logging experiencing elevated error rate while reading logs 18 Oct 2021
2 hours, 14 minutes
Global: Some Cloud Monitoring metric calculations are delayed or missing for multiple Cloud Services 13 Oct 2021
5 hours, 25 minutes
Cloud Logging experiencing issue returning results for "tail" commands globally 26 Aug 2021
28 minutes
The issue with Cloud Logging has been resolved for all affected projects. 18 Aug 2021
3 hours, 51 minutes
Elevated error rate across all monitoring API endpoints globally 6 Aug 2021
6 hours, 28 minutes
Global: Cloud Logging Query timing out 27 Jul 2021
4 hours, 12 minutes
We are experiencing an issue with Cloud Monitoring beginning at Monday, 2021-06-21 00:00 US/Pacific. 21 Jun 2021
9 hours, 34 minutes
Cloud Alerting users cannot receive notifications via Vespa, Webhook, Slack, or Pagerduty 17 Jun 2021
19 minutes
Cloud Logging Ingestion delay, causing logs to be delayed. 23 Mar 2021
8 hours, 5 minutes
Newly ingested logs may be delayed before being accessible in Cloud Logging 24 Feb 2021
1 hour, 15 minutes

2020

Summary Date Duration
Increased error rate seen for Queries to Cloud Logging. 3 Dec 2020
5 hours, 5 minutes
Cloud Logging delays on log ingestion affecting 25% of projects. 19 Nov 2020
12 hours, 27 minutes
We are experiencing an issue with Cloud Logging beginning at Friday, 2020-09-25 06:50 US/Pacific. Symptoms are increased error rates and potentially latency upon reading, filtering or querying logs. Writing logs are not affected. Mitigation work is already underway by our engineering team. The mitigation is expected to complete by Friday, 2020-09-25 11:00 US/Pacific. We will provide more information by Friday, 2020-09-25 11:30 US/Pacific at the latest. 25 Sep 2020
3 hours, 28 minutes
We are experiencing an issue with Cloud Logging and Cloud Monitoring. 24 Sep 2020
35 minutes
We are experiencing issues with Cloud Logging 20 Aug 2020
1 hour, 16 minutes
We are experiencing an issue with Cloud Monitoring. 23 Jul 2020
1 hour, 54 minutes
Cloud Composer environment creations are failing globally. 26 Mar 2020
1 hour, 15 minutes
We are investigating an alerting issue in Stackdriver Monitoring 27 Feb 2020
3 hours, 1 minute
We've received a report of an issue with Stackdriver Monitoring 17 Jan 2020
2 hours, 50 minutes
BigQuery exports for Stackdriver Logs delayed in europe-west1 13 Jan 2020
6 hours, 29 minutes

2019

Summary Date Duration
We've received a report of an issue with Stackdriver Monitoring. 11 Nov 2019
56 minutes
We've received a report of issues with multiple Cloud products including Compute Engine Internal DNS, Cloud DNS, Stackdriver Logging and Monitoring, Compute Engine, App Engine, Cloud Run, Cloud Build, Cloud Composer, and Cloud Firestore 24 Sep 2019
7 hours, 14 minutes
We investigating an Global issue with log ingestion delays on Stackdriver Logging. 9 Sep 2019
6 hours, 37 minutes
Google Stackdriver Alerts not firing reliably 26 Apr 2019
3 hours