Service Health

This page provides status information on the services that are part of Google Cloud. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact Support. Learn more about what's posted on the dashboard in this FAQ. For additional information on these services, please visit https://cloud.google.com/.

All incidents reported for Google Compute Engine

2024

Summary Date Duration
Cloud Customers may experience minimal service disruption in us-east5-c 28 Mar 2024
3 hours, 32 minutes
Issue with Google Cloud Console, Cloud Workstation, Cloud Shell, GKE and Persistent Disk. 27 Feb 2024
2 days
Multiple Google Cloud Products are experiencing issues in us-west1 14 Feb 2024
3 hours, 7 minutes
Multiple product outage in europe-west8-b 7 Feb 2024
1 hour, 59 minutes
Multi-Region: Google Cloud VMWare Engine Portal Unavailable in Google Cloud Console 23 Jan 2024
1 hour, 35 minutes

2023

Summary Date Duration
We are experiencing a reduction in the notice window for the preemption VMs. 6 Dec 2023
1 hour, 49 minutes
Google Compute Engine, Persistent Disk, Virtual Private Cloud are experiencing issues in us-east4-a 7 Nov 2023
3 hours, 55 minutes
Google Compute Engine is returning Internal errors for compute.regionInstances.recommendLocations in us-east7, us-west2, europe-north1 7 Nov 2023
1 hour, 57 minutes
Google Cloud VMWare engine is experiencing network link issues 17 Oct 2023
2 hours, 58 minutes
Multiple cloud products are experiencing networking issues in us-central1 5 Oct 2023
7 hours, 47 minutes
Google Compute Engine is experiencing elevated error rate with diskTypes.aggregatedList API method 16 Sep 2023
1 hour, 9 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 13 Sep 2023
50 minutes
Multiple services for Google Cloud Platform are impacted in us-central1-a 12 Sep 2023
3 hours, 46 minutes
Google Compute Engine is experiencing intermittent errors in multiple regions 4 Sep 2023
1 hour, 29 minutes
Windows and Linux Virtual Machines (VMs) might be unable to boot 18 Aug 2023
5 hours, 46 minutes
We are experiencing an issue with Google Compute Engine 15 Aug 2023
40 minutes
Google Compute Engine experiencing issues in us-central1 region 8 Aug 2023
5 hours, 56 minutes
Multiple GCP products affected by Increased error rates for Google Cloud APIs in us-central1 3 Aug 2023
2 hours, 13 minutes
Google Cloud Compute Engine customers may experience requests failure during compute.instances.insert operations. 26 Jul 2023
1 hour, 8 minutes
This incident is being merged with an existing incident. All future updates will be provided there: https://status.cloud.google.com/incidents/VuCtCwkRXueAyusvrXfG 12 Jun 2023
2 hours, 25 minutes
Multiple Google Cloud Platform services impacted globally with operational latency 12 Jun 2023
4 hours, 33 minutes
Google Compute Engine is experiencing elevated latency for API calls to global resources. 12 Jun 2023
2 hours, 32 minutes
Google Compute Engine and Google Kubernetes Engine are experiencing issues with some instance, node, cluster operations 8 Jun 2023
1 hour, 13 minutes
us-east1: Multiple Google Cloud Services Impacted 4 Jun 2023
1 hour, 43 minutes
Multiple Cloud products impacted in europe-west9-c zone 6 May 2023
4 hours, 30 minutes
This incident is being merged with an existing incident. All future updates will be provided there: https://status.cloud.google.com/incidents/dS9ps52MUnxQfyDGPfkY 26 Apr 2023
51 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 26 Apr 2023
1 hour, 34 minutes
Multiple Google Cloud services in the europe-west9-a zone are impacted 25 Apr 2023
1 day, 3 hours
us-east4-a: Zonal and Regional Persistent Disk Operations Latency 25 Apr 2023
1 hour, 38 minutes
Managed Instance Groups, that rely on health checks to restart unhealthy VMs, may remain in an unhealthy state 21 Apr 2023
13 hours, 8 minutes
us-east4-b: GCE instance creation failures 12 Apr 2023
2 hours, 7 minutes
Global: High Memory Issues on GCE Windows VMs using Google Cloud Ops Agent >= 2.27.0 11 Apr 2023
2 days, 4 hours
VM Manager errors for Windows VMs 31 Mar 2023
26 minutes
us-central1-c: Google Compute Engine is experiencing issues with instance create, update, or delete operations 29 Mar 2023
58 minutes
asia-east2: Google Compute Engine (GCE) is experiencing elevated latency 22 Mar 2023
2 hours, 27 minutes
Google Engineer are investigating as issue impact Google compute engine 15 Mar 2023
57 minutes
Users Unable to create VMs with older VMX versions in 4 cells 9 Mar 2023
2 hours, 38 minutes
Packet loss observed partially in asia-south1-b zone 8 Mar 2023
1 hour, 1 minute
Multiple services are being impacted globally within Google Cloud 27 Feb 2023
13 minutes
Zonal: Google Compute Engine experiencing VM operation failures in us-central1-c 15 Feb 2023
1 hour, 13 minutes
Google Cloud Networking experiencing GCLB connection errors from virtual instances. 30 Jan 2023
1 day, 6 hours
Google Cloud Console Marketplace is experiencing 404 errors. 12 Jan 2023
3 hours, 32 minutes
Google Cloud Networking is experiencing elevated error rates and packet loss in us-central1 and us-south1 10 Jan 2023
2 hours, 56 minutes

2022

Summary Date Duration
Multi Zonal: Google Compute Engine Experiencing VM failure 16 Dec 2022
1 hour, 51 minutes
Google Compute Engine. ssh fails with ERROR: (gcloud.compute.start-iap-tunnel) Error while connecting [4047: 'Failed to lookup instance'] 1 Dec 2022
1 day, 3 hours
We are investigating a potential issue with multiple Google Cloud services. 14 Nov 2022
48 minutes
Zonal: GCE VM's Experiencing delayed maintenance 9 Nov 2022
8 days, 2 hours
us-west1: Degraded performance for PD-Standard devices 27 Oct 2022
8 hours, 49 minutes
VMs using Local SSD are experiencing intermittent terminations. 26 Oct 2022
6 days, 13 hours
SEV VMs on RHEL image fail to boot in zones -a and -b in all regions 6 Oct 2022
1 hour, 16 minutes
Google Cloud Networking is experiencing issues in South America 6 Oct 2022
1 hour, 56 minutes
europe-central2-c: GCE instances not autoscaling 28 Sep 2022
1 minute
Google Engineer are investigating an issues with Cloud GCE. 14 Sep 2022
15 hours, 56 minutes
Multiple services impacted in us-central1 region 25 Aug 2022
1 hour, 1 minute
Cloud Monitoring is serving query failures, errors, and metrics unavailability impacting Google Compute Engine, Cloud Spanner, Cloud Dataflow, Cloud Bigtable, Cloud AppEngine, Kubernetes Engine, Cloud Pub/Sub, Cloud Run in us-central 20 Aug 2022
2 hours, 55 minutes
Cloud TPU V4 experiencing availability issues in us-central2-b 22 Jul 2022
5 minutes
Cooling related failure in one of our buildings that hosts zone europe-west2-a for region europe-west2. 19 Jul 2022
1 day, 15 hours
Multiple Cloud products experiencing elevated error rates, latencies or service unavailability in europe-west2 19 Jul 2022
1 day, 15 hours
Multi Region VMWare Engine - GCVE Firewall Status Failure 13 Jul 2022
1 day, 19 hours
VMWare Engine portal unavailable. 6 Jul 2022
26 minutes
vSphere vCenter and NSX may not have been available for a short period of time in us-central1 23 Jun 2022
6 hours, 23 minutes
Global: Some Google Cloud Console Customers are unable to create/edit GCE instances 14 Jun 2022
2 days, 8 hours
us-east1: Elevated errors affecting multiple services. 4 Jun 2022
6 hours, 16 minutes
We've received a report of an issue with Persistent Disk. 8 May 2022
1 hour, 38 minutes
Google Cloud Infrastructure is failing to push cloud configs 8 May 2022
3 hours, 18 minutes
Customers may experience elevated latency for inter-region in multiple asia regions. 6 May 2022
4 hours, 29 minutes
This issue is believed to be affecting a very small number of projects and our Engineering Team is working on it. If you have questions or are impacted, please open a case with the Support Team and we will work with you until this issue is resolved. No further updates will be provided here. We thank you for your patience while we are working on resolving the issue. 6 May 2022
3 hours, 29 minutes
We are experiencing an issue with Persistent Disk affecting multiple services in us-central1-b 6 May 2022
10 hours, 36 minutes
Google engineering are investigating issues with Cloud Networking, starting at 2022-02-10 00:32:56 PST 10 Feb 2022
6 hours, 2 minutes
US-WEST1: Multiple cloud products experiencing network issues 8 Jan 2022
3 hours, 21 minutes

2021

Summary Date Duration
Global: pubsub.googleapis.com autoscaling not worked as expected 7 Dec 2021
6 days, 15 hours
Some Users might have received credit cards deemed invalid email erroneously. 12 Nov 2021
1 hour, 15 minutes
Global: We have identified a Networking connectivity issue that impacts Docker workloads inside GKE and potentially GCE. Mitigation in progress. ETA - 00:00 PST, 29th Sept. 27 Sep 2021
1 day, 21 hours
Increased VM failure rates in a subset of Google Cloud zones 17 Sep 2021
3 hours, 25 minutes
Global: Cloud Networking connectivity issues for customers using packet mirroring. 13 Sep 2021
4 days, 15 hours
europe-west2-c: Cloud networking is currently experiencing issues. 3 Sep 2021
40 minutes
us-central1, europe-west1, us-west1, asia-east1: Issue with Local SSDs on Google Compute Engine. 31 Aug 2021
2 days, 1 hour
We are experiencing a connectivity issue affecting Persistent Disk in australia-southeast2 23 Aug 2021
1 hour, 31 minutes
Google Cloud infrastructure components faced issues in australia-southeast2 starting 2021-08-23 19:50 PDT. Most of the services are fully restored by 2021-08-23 21:20 PDT. 23 Aug 2021
1 hour, 30 minutes
We've been informed that Cloud Networking, and Load Balancer, are not functioning in europe-west2 6 Aug 2021
3 hours, 45 minutes
Mutliregional Price for E2 Free Tier core is set incorrectly 1 Aug 2021
3 days, 16 hours
Persistent Disk SSD creation is failing in us-east1-{b,c,d}, us-east4-{a,b}, us-west1-c and us-west4-a. This may impact creation of resources which depend on Persistent Disk SSD such as Google Compute Engine, Google Kubernetes Engine, Cloud Composer, Cloud SQL, Cloud Dataproc, and Apigee X in those same regions 19 Jun 2021
3 days, 10 hours
Issue with multiple Google Cloud infrastructure components. 20 May 2021
10 hours, 45 minutes
Requests to and from Google Compute Instances in us-west2 may see increase traffic loss when using the instance's public IP 4 May 2021
2 hours, 44 minutes
Customers may experience traffic loss across multiple products with requests destined to and from us-west2 4 May 2021
5 hours, 33 minutes
Increased latency and packet loss 17 Mar 2021
4 hours, 30 minutes
The issue with Google Compute Engine VM instance creation and deletion is partially resolved as of 15:14 US/Pacific. 18 Feb 2021
3 hours, 42 minutes
Our engineers have determined this issue to be linked to a single Google incident. For regular status updates, please visit https://status.cloud.goog 12 Feb 2021
4 hours, 5 minutes

2020

Summary Date Duration
Cloud GCE resources may be unreachable in europe-west2-a 9 Dec 2020
1 hour, 39 minutes
Elevated frequency of Host Maintenance events on GCE instances with an attached GPU(s) and SSD(s) 10 Nov 2020
21 hours, 20 minutes
GCE instance creation/start/stop operations failing in us-central1-f 30 Oct 2020
8 hours, 29 minutes
We are currently experiencing an issue with Google Compute Engine customers experiencing elevated rates of packet loss in southamerica-east1-{a, b, c} due to the ongoing Cloud Networking issue beginning at Monday, 2020-10-19 13:05 US/Pacific. 19 Oct 2020
39 minutes
We are experiencing an issue with Google Compute Engine instances running RHEL and CentOS 7 and 8. Instances running RHEL and CentOS 7 and 8 that run yum update may fail to boot after restart. 30 Jul 2020
4 hours, 38 minutes
Issue with Compute Engine API 28 Jul 2020
3 hours, 35 minutes
We are experiencing an issue affecting multiple Cloud services. 23 Jul 2020
1 hour, 42 minutes
Issue creating and deleting Compute Engine instances 14 Jul 2020
3 hours, 40 minutes
We are experiencing an issue with Google Compute Engine in us-east1-c and us-east1-d 29 Jun 2020
1 hour, 26 minutes
We are experiencing issues with Google Compute Engine Autoscaling in us-east1-c 29 Jun 2020
3 hours, 25 minutes
We are investigating an issue with elevated error rates across multiple Google Cloud Platform Services 8 Apr 2020
54 minutes
We've received a report of an issue with Google Compute Engine. 26 Mar 2020
11 hours, 8 minutes
We have received a report of issues with Google Compute Engine. 26 Mar 2020
54 minutes
Elevated error rates across multiple Google Cloud Platform services. 26 Mar 2020
13 hours, 41 minutes
The issue with instance DELETE and STOP operations in Google Compute Engine has been mitigated. 28 Jan 2020
1 day, 4 hours

2019

Summary Date Duration
Issues with PD-SSD in us-east1-b zone 7 Dec 2019
3 hours, 7 minutes
We are investigating an issue with network connectivity in asia-southest1 3 Dec 2019
22 minutes
We've received a report of an issue with Cloud Firestore. 11 Nov 2019
2 hours, 21 minutes
We've received a report of an issue with Google Compute Engine. 11 Nov 2019
1 hour, 44 minutes
Some networking update/create/delete operations pending globally 31 Oct 2019
1 day, 22 hours
We are investigating an issue with Google Compute Engine. 22 Oct 2019
3 hours, 43 minutes
We've received a report of an issue with Cloud Networking. 22 Oct 2019
4 hours, 48 minutes
We've received a report of issues with multiple Cloud products. 24 Sep 2019
5 hours, 8 minutes
Issues creating instances and deploying apps in asia-east2. 5 Sep 2019
13 hours, 17 minutes
We are experiencing a multi-region issue with Google Compute Engine 2 Jun 2019
3 hours, 55 minutes
The network congestion issue in eastern USA, affecting Google Cloud, G Suite, and YouTube has been resolved for all affected users as of 4:00pm US/Pacific. 2 Jun 2019
3 hours, 55 minutes
The issue with Persistent Disk in us-central1-a zone has been resolved for all affected users. 15 May 2019
5 hours, 2 minutes
The Google Compute Engine is experiencing ZONE_RESOURCE_POOL_EXHAUSTED errors when creating new Compute instances in us-east4 region. 11 May 2019
2 hours, 12 minutes